Fix Devices and Printers not Loading in Windows 10

Many users have reported a strange issue where the Devices and Printers menu shows empty. Ideally, even if the printer isn’t connected, some or the other device or a virtual printer would show there.

 

Devices And Printers Not Loading

 

Causes

The causes could be many, but since lesser users are reporting this issue now, we could assume that Microsoft is aware of the same and is pushing fixes through Windows updates. The most common reasons for this problem are as follows: malware or virus, Print Spooler service is not running, Bluetooth service is not running, Internet Explorer 8 DLL is not properly registered, Corrupted system file, issues with the drivers, and issues with the hardware.

Since we have a wide range of issues to sort out, we will follow the solutions sequentially, isolating each possibility step by step.

Solution 1] Perform a Windows update

This would be the most important step. As mentioned earlier, since less users are reporting this problem with time, it is quite possible that Microsoft is aware of the issue and is pushing the resolution in form of Windows updates. Here is the procedure to update your Windows 10 operating system.

Solution 2] Full anti-virus scan

As weird as the issue is, we cannot ignore the possibility of a malware or virus causing it. Run a full anti-virus and anti-malware scan on your system to check for issues.

Solution 3] Check for suspicious recently installed programs

Usually freeware pushes malware along with it. While an antivirus scan can remove the malware, it is important to remove the suspicious program as well.

1] Press Win + R to open the Run window and type the command control panel. Press Enter to open the Control Panel window.

2] Go to Programs and features. It would list all the programs installed on the system. Arrange them in the order of the date of their installation.

 

Arrange As Per Installation Date

 

 

3] Right-click and uninstall any suspicious programs.

4] Restart the system.

Solution 4] Run the Hardware and devices troubleshooter

The Hardware and devices troubleshooter could be helpful in checking issues finding the devices on the system.

1] Click on the Start button and then the gear-like symbol to open the Settings menu.

2] Go to Updates and security and then the Troubleshoot tab.

3] Select the Hardware and devices troubleshooter and run it.

 

Hardware And Devices Troubleshooter

 

4] Restart the system.

Solution 5] Update the drivers

Updating the “Print queues” drivers could help with the issue. Here is the procedure to update the drivers in Windows 10.

Solution 6] Run an SFC scan

1] Search for Command Prompt on the Windows search bar and right-click on the icon. Select Run as administrator.

2] Type the command sfc /scannow in the administrative Command Prompt window and press Enter to execute it.

 

Sfc Scan

 

3] Restart the system.

Solution 7] Registering the IE8 DLL

One of the reasons we find the Devices and Printers menu empty is when the Internet Explorer’s DLL’s are missing. The same could be registered through Command Prompt.

1] Search for Command Prompt on the Windows search bar and right-click on the icon. Select Run as administrator.

2] Type the following command and press Enter:

 

regsvr32  “%ProgramFiles%\Internet Explorer\ieproxy.dll”

 

Command Prompts Command

 

3] Once the command has executed, exit Command Prompt and restart the system.

Solution 8] Enabling the Bluetooth Support and Print Spooler service

The Bluetooth support and Print Spooler service could be started and set to default to help with this issue. The procedure is as follows:

1] Press Win + R to open the Run window and type the command services.msc. Press Enter to open the Service manager window.

2] Right-click on the Print spooler service and then on Properties.



3] Change the startup type to automatic and then click on Start to start the service.

 

Start The Print Spooler Service

 

4] Click on Apply and then on OK.

5] Restart the system and check if it resolves the issue.


css.php